FireBible 1.4 Released


I released FireBible 1.4 early this morning, this release fixes issues with recent Java 7 updates and Firefox 16 and above, as discussed in my last post. I also threw in a few minor bug fixes.

As usual, if you already have FireBible installed, simply check for updates (I’ll be updating the AMO version later today) . To install a fresh copy, head on down to the FireBible page.

A longer term update:

  • FireBible still won’t work with the IcedTea Java plugin on Linux (unless you remove almost all security settings, not recommended). So you will still need an Oracle Java installation on Linux for FireBible to work.
  • Still no av11n (alternate versification) support as I need to wait for this to be added to the JSword library. Full support for deuterocanonical books (including the Catholic Bible :() therefore not present yet. Hopefully soon.
  • Ubiquity support still cool (I consider this to be one of FireBible’s best features) – but you need the privately maintained Ubiquity 0.6 version or higher; you can get that here (download the file and select it in the File > Open dialog to install).
  • Will investigate the viability of switching to the native Sword libraries as opposed to Java based JSword:
    • Pros
      • No Java installation required, extension should work out of the box.
      • Security issues keep cropping up with “Java in the browser”. There are restrictions that are either imposed by Firefox itself or changes in Java internals that affect “not so common” use of Java. Hopefully we’ve seen the last of these.
      • av11n support already present in native Sword libraries.
    • Cons
      • Will lose JSword specific UI such as the module installer and settings.
      • Implementation will be harder and take time which I do not currently have.
      • Will need to build separate versions of the extension for each platform (currently not required due to the use of Java libraries).

,

  1. No comments yet.
(will not be published)